User Tools

Site Tools


ufit:help:install

How to install ufit

Ufit is possible to use in two ways - as a software with rich GUI (graphical user interface) or as a library in Python. Some features are not yet implemented in GUI, like global fitting of more datasets.

Install only GUI (Windows only)

This option does not require installation of python and can be installed on any Windows computer. Just download latest windows installer, confirm that you want to run it and install it as any other Windows program. After the installation, just run ufit from Start menu (type ufit in start menu of Windows 10). Ufit should run on any 32 or 64 bit version of Windows XP/Vista/7/8/10.

Standalone installation of GUI is not supported on other platforms. But gui is always included in library version.

Install whole ufit package with scripting support

In order to use whole ufit, you need to have Python installed. We recommend to use Anaconda distribution, which is open source and available for all major platforms.

How to install Anaconda?

Ufit is included in pip repository, so it is easy to install:

pip install ufit

General requirements

  • Python 2.7
  • Python 3 with pyqt4 (to support gui)

ufit is fully compatible with python 3, but in order to use GUI, you need to have pyqt4. If you are using anaconda distribution, you need to downgrade to python 3.5, because version 3.6 does not include pyqt4. Then you need to downgrade to pyqt4:

conda install python=3.5
conda install -c anaconda pyqt=4.11.4
ufit/help/install.txt · Last modified: 2017/03/30 16:29 by Petr Cermak